Tag Archives: handhelds

Battle Squadron on ALL iOS 4.0 devices

The first version of Battle Squadron required minimum iPad, iPhone 3GS, or iPod 3rd generation. The coming version will run on iPhone 3G and iPod 2nd generation as well. Advertisements

Posted in Cope-Com games | Tagged , , , , , , , , , , , , , , , , , , , , | 11 Comments